Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.

Log in or register to post/reply in the forum.

PakBus framing errors - reboot clears this up for a short time

tjwilli_58 Oct 13, 2022 01:10 PM

I'm having a similar problem to this question posed back in 2012:

CR200X getting PakBus framing error Invalid low level signature - Campbell Scientific User Forums

I have a 4 CR3000s and a CR800 on a PakBus network at one site. At another site, I have 3 CR3000s on a different PakBus network. A third site has a single CR3000.  LoggerNet is configured identically as far as I can tell, but on the first site, I keep getting messages like:

"2022-10-13 7:41:08 AM","PakBusPort","F","PakBus framing error","Invalid low level signature"
"2022-10-13 7:41:19 AM","PakBusPort","S","sending message","src: 4094","dest: 1","proto: BMP5","type: 0x18","tran: 46"
"2022-10-13 7:41:19 AM","SITE01","W","transaction failure","timed out or resource error","Get Logger Program Status"
"2022-10-13 7:41:19 AM","PakBusPort","S","received message","src: 1","dest: 4094","proto: BMP5","type: 0x98","tran: 46"
"2022-10-13 7:41:19 AM","SITE01","S","BMP5 message received","type: 0x98","Get Logger Program Status"
"2022-10-13 7:41:19 AM","PakBusPort","S","sending message","src: 4094","dest: 10","proto: BMP5","type: 0x09","tran: 25"
"2022-10-13 7:41:19 AM","ComPort","W","character buffer overrun"
"2022-10-13 7:41:19 AM","ComPort","S","Valid data received after comm errors"
"2022-10-13 7:41:19 AM","ComPort","W","character buffer overrun"
"2022-10-13 7:41:19 AM","ComPort","S","Valid data received after comm errors"
"2022-10-13 7:41:19 AM","ComPort","W","character buffer overrun"
"2022-10-13 7:41:19 AM","ComPort","S","Valid data received after comm errors"

Basically, I having problems downloading my data on the first site. This has been going on for quite awhile, and the only solution I've found so far is that if I reboot the collection computer, something gets freed up and the data on the various dataloggers starts to download for a while. After a few minutes, I start to get the "PakBus framing error" messages again. Depending on how much data is backlogged on the dataloggers to download, I need to reboot several times to get caught up. 

This started happening several months (over a year?) ago after that computer was replaced. LoggerNet was reinstalled, but I can't see what the difference is between the setup of the problem site and the site that works just fine. 

It seems to be Windows issue, since rebooting clears up my problem for a while. My IT people deny this though.

I'm stumped. Any help on how I can track this down is appreciated. 

JDavis Oct 19, 2022 04:14 PM

If you are using a radio network, interference can cause framing errors. Framing errors can also happen with bad USB to RS232 cables.

Comport buffer overruns point to the computer. The amount of data that comes in through is comport is relatively slow. Any computer made in the last 30 years probably doesn't let the buffers hit more than two deep. The comport probably has at least 16 buffers.

So, something is really bogging down the computer, the comport driver has problems, or there is damaged comport hardware. Look at the Windows performance monitor next time it happens to see if something is using all the memory or CPU time.

tjwilli_58 Oct 19, 2022 05:03 PM

Thanks for the reply. I'll copy this to the IT person I've been working with. I believe the USB to Serial adapter was changed. We have tried tweaking the comport settings w/o success. I hadn't thought about looking the the Windows performance monitor. Things run fine on a fresh boot for a few minutes, so *something* is probably stealing cycles later on that's affecting this. 

tjwilli_58 Oct 20, 2022 12:48 PM


I didn't get any clues using the Windows performance monitor, but I did find out that the other (working) site has an on-board RS-232 port, and the site I'm having issues with is using a USB/serial adapter. A new/updated driver was tried for this computer w/o success. Perhaps a different adapter is needed.

These computers are using FreeWave radios BTW. 

Do you recommend any particular models for a USB/Serial adapter?


JDavis Oct 21, 2022 05:08 PM

For USB to serial adapters, you want to find ones with FTDI chips. If an adapter uses an FTDI chip, it usually says in the product specifications. If it does not, assume it uses a cheaper brand of chip.

Campbell Scientific switched to only selling cables with FTDI chips in 2013 because of driver issues.

Freewave also recommends in their documentation to use FTDI chips.


Adapters with FTDI chips cost more, but the total cost is still quite low.

BerthaPeachey Dec 16, 2022 05:57 AM

This post is under review.

tjwilli_58 Mar 24, 2023 12:31 PM

I've been  meaning to do a follow-up to this for a while now. Apologies. We got a newer USB to serial adapter with the FTDI chip, and everything works just fine! Thanks to JDavis for the suggestion.

Log in or register to post/reply in the forum.